x

I just purchased and downloaded the VSPro version. Whenever I launch Reflector.exe (double click in windows explorer) I get an application popup with the following message: "Application Error : The application was unable to start correctly (0xc000007b). Click OK to close the application." I click OK and it closes. There is an Informational event in the System log. The source is Application Popup. There's no other events in System or Application that consistently occur at the same time.

I'm running Windows 7 Ultimate and logged on with an account in the administrators group. I've copied the contents of the zip package to a folder in "Program Files", "Program Files (x86)" and "My Documents" and tried launching from all locations. I've tried using "Run as Administrator". I've tried the Compatibility Troubleshooter which I believe tried changing the compatibility settings to Windows XP SP 2. (I just recently moved from a 32 bit Win XP machine to a 64 bit Win 7 machine, so I'm new to the world of 64 bit, UAC and compatibility issues.)

I googled the error message and found several postings stating that the error code is INVALID_IMAGE_FORMAT. Mostly they suggested reinstalling. So I downloaded the zip package a couple more times and still get the same thing. I downloaded and tried it from my Win XP machine and it works fine. I tried using 7zip and the native windows explorer unzip. I also Unblocked the exe and dll files. (Only needed to do that when unzipping through explorer.)

I verified that versions 2.0, 3.0, 3.5 and 4.0 of the .NET Framework were installed, with the latest service packs, using the method described here: [http://support.microsoft.com/kb/318785/en-us](http://support.microsoft.com/kb/318785/en-us "How to determine which versions and service pack levels of the Microsoft .NET Framework are installed").

What am I missing?

Thanks, Paul
more ▼
asked May 25 '11 at 04:43 PM paulbolejack 21 paulbolejack gravatar image
nick_maidment gravatar image nick_maidment ♦♦ May 25 '11 at 05:06 PM

We've seen this kind of error before but not managed to get to the root cause of it.

Are you getting any related errors in the windows application or system event logs?

Are you using the windows unzip mechanism or another zip program?

Also can you try following the instructions to "unblock" the files in the zip: http://blog.rthand.com/post/2010/05/30/Getting-HRESULT-0x80131515-when-running-Righthand-DataSet-Visualizer.aspx
paulbolejack gravatar image paulbolejack May 25 '11 at 10:34 PM
I edited the question to add the event log & unzip info. I'll also add that the first time I looked for other events occurring at the same time I found an AuditFailure in the Security log caused by a ZoneAlarm dll. But only that one time. See: http://forums.zonealarm.com/showthread.php?t=74741 and http://forums.zonealarm.com/showthread.php?t=71997. I shutdown ZoneAlarm and still got the Reflector error. (However, after shutting down ZoneAlarm, Process Explorer showed that dll still attached to a dozen processes.)
nick_maidment gravatar image nick_maidment ♦♦ May 26 '11 at 10:52 AM

Thanks for the info, I've just reproduced this here. Now we just have to work out what we can do about it.

edit: This seems to be down to the ZoneAlarm Toolbar IswSvc which doesn't get shutdown if you shutdown the security suite.
paulbolejack gravatar image paulbolejack Jun 24 '11 at 09:42 PM
Any idea on a time frame for this? Is this something I could also report to ZoneAlarm? I'm doing some DotNetNuke development = Open Source = sometimes buggy & almost always lacking documentations... I bought the VSPro version to step through all the 3rd party librarys without having setup all of the source packages.
nick_maidment gravatar image nick_maidment ♦♦ Jun 27 '11 at 10:35 AM

Sorry for the delay in getting back to you. We're still waiting for feedback from the people at ZoneAlarm. We've logged a ticket with them but haven't heard anything back as yet. This is definitely something you could also report to them.

There is a (rather horrible) workaround for it which is to disable the IswSvc Service.

Alternatively I managed to get the two products to work side by side on a 32bit VM
(comments are locked)
10|600 characters needed characters left

Be the first one to answer this question
osqa.question.ask.tags.preview.show

Up to 2 attachments (including images) can be used with a maximum of 524.3 kB each and 1.0 MB total.